It appears Maguss is not compatible with iOS 9.3.5

  • Basically since my phone is broken right now I had to try with my iPad 2, running iOS 9.3.5, and it did the same things (crashing as soon as the loadin screen came up) as many other apps which are not compatible with older versions. I figure you guys probably know about this, but I thought it couldn't hurt to mention it in case you didn't.

Log in to reply

Looks like your connection to Maguss forum was lost, please wait while we try to reconnect.