Can't cast spells



  • Hello,

    first of all I have to say that your game is really great!
    But I have a problem. I just started today, so maybe I just don't know the answer but also maybe it's a bug. Very often after a few rounds I can't cast spells anymore even though the overheat is very low or at 0. Usually I try to cast spells for another three or four rounds but nothing happens anymore.
    I would really appreciate it if you could tell me that I'm just missing some kind of information here :D

    Anyway keep up the good work!



  • @lenyed

    Hi lenyed. Welcome to our happy band of testers.

    The inability to cast, or more specifically, the inability for your device to recognize the glyph can sometimes be remedied by turning off the auto rotate feature on your phone. For myself, since I have done this I have yet to experience that issue.

    I hope that helps.



  • @robynoakwise Thank you for your quick response.

    I never activate auto-rotate so I'm afraid that can't be it. It's not that a single spell isn't recognized, I can't cast ANY spells, anyway how often I try and how many rounds pass.



  • @lenyed

    Please don't think this is a silly question or mean but have you set spells in your casting slots? Then used the training dummy that is available to test your glyph skills?



  • @robynoakwise Yes :D
    I'll try describing it: The fight begins, I cast my spells, everything's fine. But after a not specified number of rounds (can be 3 but also 5), no spells are accepted anymore. Often I wasn't able to cast the healing spell (in the second slot), but still the attacking spell (in the first slot). But it is always that about two rounds after the healing spell isn't working anymore the attacking spell stops working, too.
    I tried sitting it out but I never have enough health to live very long. So I have to give up or die. As I said before, overheat can't be it because it's very low or 0 at the time.

    Just in case it's relevant: I'm playing on a Samsung Galaxy S4 Zoom with Android 4.4.2



  • i get it too, at random.

    Devs have tried to improve it and recommends setting the phone on a stable/level surface.
    Something to do with the phone's internal gryo.

    even after practising the above, it still happens.



  • @tc4237
    The issue occurs at home, too...so the stable surface isn't really a solution for me.
    And yeah, I wanted to add that it doesn't happen with every fight. Often but not everytime



  • @lenyed After several attempts, I can now reliably reproduce this. It appears to be a problem for combats where the monster is standing right at the edge of range.

    Using a car (me as passenger, not driver!), I can start a combat at a stop, then have driver drive away, and pretty much immediately, I get locked out of combat. Driving down the highway at 75 mph, I can grab resources, but no combat allowed.

    I assume there's some sort of "if you walk away from the fight" code getting involved, but that's purely a guess.

    So what I did was pick a fight with monsters right as they entered my range. For those monsters, shaking my phone was enough to cause the lockout. For monsters that came right up on me, I didn't have the issue.

    Can anyone else replicate this result?



  • @lenyed said in Can't cast spells:

    @robynoakwise Yes :D
    The fight begins, I cast my spells, everything's fine. But after a not specified number of rounds (can be 3 but also 5), no spells are accepted anymore.

    I get this sometimes too. Sometimes it's 3-5 rounds as you said, sometimes it's over 10 rounds (Treants, heh).

    Sometimes I can cast slot-2 but not 1, 3, 4 or 5... Etc. And this is after all 5 slots work 100% perfectly for the first "good" rounds.

    This is a definite bug; not surprising since glyph bugs have been kind of the major thing during this Alpha.

    This is on a Google Pixel, on Android O. (So it's not limited to one phone or one Android version.)



  • I'm somewhat relieved that it's not only me although I'd wish you a great experience without this.

    I'd like to add that I started the game just yesterday so I don't have much evidence but it's so much worse today than yesterday when I first started this topic.
    Now it's often from the first round that I can't fight and from 10 battles I have the problem 7 times.

    So if there was an update (the game told me there was but the play store didn't show any and after that I was able to start it again) maybe there was something in it that made it worse.



  • Guys, there's an update in play store for android. (released less than a few hours)
    There wasn't a notification. I had to search for the game then only I saw the update option.
    As I'm not on WiFi, I can't update yet.

    Practically every pve match this evening,i had the glyph bug. This update is probably why. (usually it's just random 2-4 matches out of 5)



  • I have the update, it does not fix the problem.



  • No, it doesn't.

    But thank you for your hint :)



  • Same here, I am suffering from this problem. I have also noticed some flickering in the image after engaging in a combat. What I find stands out in the glyph recognition bug, is that after turn 3 or 5, the dust trails of your movement always adopt the shape of the first spell in your deck. Mostly for me this is the up - down one. I can try to do any other movement it always shapes itself into the up-down glyph. When executing that motion the spells does cast. So from what I can see the casting gets stuck or confused and limits itself to the first spell in your deck.



  • @alex-schoeffner said in Can't cast spells:

    the dust trails of your movement always adopt the shape of the first spell in your deck.

    Yes! This is correct; I forgot to mention this. When the bug happens, any attempt to draw any glyph always results in the dust trail taking on the shape of the Slot 1 glyph (which is always the Arrow symbol; glyphs are tied to slots now - not spells). However, I find I can't even cast the Slot 1 spell when bugged. The dust trail does take on the shape (as it will with any glyph during the bug) but it won't cast.



  • @vendraen said in Can't cast spells:

    @alex-schoeffner said in Can't cast spells:

    the dust trails of your movement always adopt the shape of the first spell in your deck.

    Yes! This is correct; I forgot to mention this. When the bug happens, any attempt to draw any glyph always results in the dust trail taking on the shape of the Slot 1 glyph (which is always the Arrow symbol; glyphs are tied to slots now - not spells). However, I find I can't even cast the Slot 1 spell when bugged. The dust trail does take on the shape (as it will with any glyph during the bug) but it won't cast.

    Exactly!^
    And I also have the flickering image after battle.


  • Global Moderator

    This problem has been around for a while, and is actually several issues with the same result.

    1. Gyroscope: it has been confirmed that the Gyroscope affects the Glyph recognition, thus the reason it is recommended to keep the phone steady when playing, you don't need to necessarily place it on a table, but that can help.
    2. Range: it also happens when you attack a creature at the edge of your Action circle, if the creature moves out of the circle, either by you or it wandering, it will start to cause issues with Glyph recognition. Sometimes it will start working again if you or it move closer together, getting the Creature back within your circle. This went away for a while when they stopped the Creature movement for a bit, but its back with the creature movement.
    3. GPS: Same as above, if your phone or the area you are in has poor GPS, and you "port" away, its basically the same as #2
    4. Difficulty: There has been confirmation, though the dev's weren't sure why the last time I spoke with them about it, but the Glyphs seem to become more difficult as the battle goes on. We don't see this one as much since duels of 20+ turns aren't seen too much anymore.
    5. Other: it is believed that there may be other issues causing the same symptoms as well, but they are hard to track down until the current known ones are fixed.

    With so many things causing the same issue, its hard to narrow down how a Fix provided for one of them is working, thus the reason they talk about using the stable surface as that will, at least for now, curb that issue to see what else might be happening.



  • Thank you everyone for your replies.
    I tried it again for about an hour and going relatively nearby to the monsters before attacking and staying approximately in one spot while fighting actually seemed to help!
    More often than not I could fight till the end and defeat the monsters so I think staying close to it is essential for a successful battle! :)



  • I can tell my experience, maybe it can be useful for developers (I don't know, I hope, worth to try). Me and my boyfriend usually play together, walking or at home, so evetime we have same signal, but I experienced that bug only 2-3 times since I play, but it happens really really often to my boyfriend. We read about bug already and when he tried all, like fix gps, don't move the phone etc. it become just a bit better, but absolutely it's still often. Using the same signal and the same tricks (I must say I had the autorotate always off by default, and maybe it helped since I start the game) but still experiencing a big difference in how often the bug happens, problem seems to be on devices for us. My is a Huawei Honor 8, his a Huawei p 9 (so not totally different).
    Another thing I'm thinking about probably sound a bit silly: I'm not so good at casting spells fast due my long nails, but maybe that help to prevent the bug. Another big difference from me and my boyfriend is that I cast less fast, I'm used to use 5 casts rarely on one turn. When I had the bug was a very long duel and before I had block I notice the spell lines was more difficult than usual to draw and graphics glitters persist too long than usual. I tried to be faster that time. May the graphics spells lines can made a "tilt" and cause the bug? My usual game style is using just few spells and draw they slow and clear just one time instead trying a lot of times fast. It can make sense if the bug happens less on high level players that maybe learned well how to draw lines exactly in sequence. But I'm not into game development I'm sorry if this sound stupid/crazy ^^"


Log in to reply
 

Looks like your connection to Maguss forum was lost, please wait while we try to reconnect.